GLSA-200812-16 : Dovecot: Multiple vulnerabilities

This script is Copyright (C) 2008-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-200812-16
(Dovecot: Multiple vulnerabilities)

Several vulnerabilities were found in Dovecot:
The 'k'
right in the acl_plugin does not work as expected (CVE-2008-4577,
CVE-2008-4578)
The dovecot.conf is world-readable, providing
improper protection for the ssl_key_password setting
(CVE-2008-4870)
A permanent Denial of Service with broken mail
headers is possible (CVE-2008-4907)

Impact :

These vulnerabilities might allow a remote attacker to cause a Denial
of Service, to circumvent security restrictions or allow local
attackers to disclose the passphrase of the SSL private key.

Workaround :

There is no known workaround at this time.

See also :

http://www.gentoo.org/security/en/glsa/glsa-200812-16.xml

Solution :

All Dovecot users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=net-mail/dovecot-1.1.7-r1'
Users should be aware that dovecot.conf will still be world-readable
after the update. If employing ssl_key_password, it should not be used
in dovecot.conf but in a separate file which should be included with
'include_try'.

Risk factor :

Medium / CVSS Base Score : 6.4
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:N)

Family: Gentoo Local Security Checks

Nessus Plugin ID: 35108 (gentoo_GLSA-200812-16.nasl)

Bugtraq ID:

CVE ID: CVE-2008-4577
CVE-2008-4578
CVE-2008-4870
CVE-2008-4907