MySQL Enterprise Server 5.0 < 5.0.70 Privilege Bypass

This script is Copyright (C) 2008-2011 Tenable Network Security, Inc.


Synopsis :

The remote database server is susceptible to a privilege bypass
attack.

Description :

The version of MySQL Enterprise Server 5.0 installed on the remote
host is earlier than 5.0.70. In such versions, it is possible for a
local user to circumvent privileges through the creation of MyISAM
tables employing the 'DATA DIRECTORY' and 'INDEX DIRECTORY' options to
overwrite existing table files in the application's data directory.

Note that this issue was supposed to have been addressed in version
5.0.60, but the fix was incomplete.

See also :

http://bugs.mysql.com/bug.php?id=32167
http://dev.mysql.com/doc/refman/5.0/en/news-5-0-70.html
http://www.openwall.com/lists/oss-security/2008/09/09/20
http://www.openwall.com/lists/oss-security/2008/09/16/3

Solution :

Upgrade to MySQL Enterprise version 5.0.70 or later.

Risk factor :

Medium / CVSS Base Score : 4.6
(CVSS2#AV:L/AC:L/Au:N/C:P/I:P/A:P)

Family: Databases

Nessus Plugin ID: 34727 ()

Bugtraq ID:

CVE ID: CVE-2008-4098