HP System Management Homepage < 2.1.15.210 Unspecified XSS

This script is Copyright (C) 2008-2014 Tenable Network Security, Inc.


Synopsis :

The remote web server is affected by a cross-site scripting
vulnerability.

Description :

The remote host appears to be running HP System Management Homepage
(SMH), a web-based management interface for ProLiant and Integrity
servers.

The version of HP SMH installed on the remote host fails to sanitize
user input to an unspecified parameter and script before using it to
generate dynamic HTML. A remote attacker may be able to exploit this
issue to cause arbitrary HTML and script code to be executed by a
user's browser in the context of the affected website.

See also :

http://www.nessus.org/u?ea065b75
http://archives.neohapsis.com/archives/bugtraq/2008-10/0069.html

Solution :

Upgrade to HP System Management Homepage v2.1.15.210 or later.

Risk factor :

Medium / CVSS Base Score : 4.3
(CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N)
CVSS Temporal Score : 3.6
(CVSS2#E:F/RL:OF/RC:C)
Public Exploit Available : true

Family: CGI abuses : XSS

Nessus Plugin ID: 34694 (hpsmh_2_1_15_210.nasl)

Bugtraq ID: 31663

CVE ID: CVE-2008-4411