GLSA-200809-16 : Git: User-assisted execution of arbitrary code

This script is Copyright (C) 2008-2015 Tenable Network Security, Inc.

Synopsis :

The remote Gentoo host is missing one or more security-related

Description :

The remote host is affected by the vulnerability described in GLSA-200809-16
(Git: User-assisted execution of arbitrary code)

Multiple boundary errors in the functions diff_addremove() and
diff_change() when processing overly long repository path names were

Impact :

A remote attacker could entice a user to run commands like 'git-diff'
or 'git-grep' on a specially crafted repository, possibly resulting in
the remote execution of arbitrary code with the privileges of the user
running the application.

Workaround :

There is no known workaround at this time.

See also :

Solution :

All Git users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=dev-util/git-'

Risk factor :

High / CVSS Base Score : 7.5

Family: Gentoo Local Security Checks

Nessus Plugin ID: 34297 (gentoo_GLSA-200809-16.nasl)

Bugtraq ID:

CVE ID: CVE-2008-3546