GLSA-200809-05 : Courier Authentication Library: SQL injection vulnerability

This script is Copyright (C) 2008-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-200809-05
(Courier Authentication Library: SQL injection vulnerability)

It has been discovered that some input (e.g. the username) passed to
the library are not properly sanitised before being used in SQL
queries.

Impact :

A remote attacker could provide specially crafted input to the library,
possibly resulting in the remote execution of arbitrary SQL commands.
NOTE: Exploitation of this vulnerability requires that a MySQL database
is used for authentication and that a Non-Latin character set is
selected.

Workaround :

There is no known workaround at this time.

See also :

http://www.gentoo.org/security/en/glsa/glsa-200809-05.xml

Solution :

All Courier Authentication Library users should upgrade to the latest
version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=net-libs/courier-authlib-0.60.6'

Risk factor :

Medium / CVSS Base Score : 5.1
(CVSS2#AV:N/AC:H/Au:N/C:P/I:P/A:P)

Family: Gentoo Local Security Checks

Nessus Plugin ID: 34104 (gentoo_GLSA-200809-05.nasl)

Bugtraq ID:

CVE ID: CVE-2008-2667