Cisco Secure Access Control Server (ACS) CSuserCGI.exe Multiple Remote Overflows

This script is Copyright (C) 2008-2013 Tenable Network Security, Inc.


Synopsis :

The remote web server contains a CGI script that is affected by
multiple buffer overflow vulnerabilities.

Description :

Multiple buffer overflows exist in the 'securecgi-bin/CSuserCGI.exe'
CGI included with User-Changeable Password (UCP) before 4.2 in Cisco
Secure Access Control Server (ACS) for Windows and ACS Solution
Engine.

A remote attacker can leverage these vulnerabilities to execute
arbitrary code via a long argument located immediately after the
'Logout' argument, and possibly unspecified other vectors.

See also :

http://www.nessus.org/u?578e73a1
http://www.securityfocus.com/archive/1/489463/30/0/threaded
http://www.cisco.com/warp/public/707/cisco-sa-20080312-ucp.shtml

Solution :

Upgrade to UCP Version 4.2 or later.

Risk factor :

Critical / CVSS Base Score : 10.0
(CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.3
(CVSS2#E:F/RL:OF/RC:C)
Public Exploit Available : true

Family: CISCO

Nessus Plugin ID: 33943 ()

Bugtraq ID: 28222

CVE ID: CVE-2008-0532