Apache < 2.2.9 Multiple Vulnerabilities (DoS, XSS)

This script is Copyright (C) 2008-2013 Tenable Network Security, Inc.

Synopsis :

The remote web server may be affected by several issues.

Description :

According to its banner, the version of Apache 2.2 installed on the
remote host is older than 2.2.9. Such versions may be affected by
several issues, including :

- Improper handling of excessive forwarded interim
responses may cause denial of service conditions in
mod_proxy_http. (CVE-2008-2364)

- A cross-site request forgery vulnerability in the
balancer-manager interface of mod_proxy_balancer.

Note that the remote web server may not actually be affected by these
vulnerabilities. Nessus did not try to determine whether the affected
modules are in use or to check for the issues themselves.

See also :


Solution :

Either ensure that the affected modules are not in use or upgrade to
Apache version 2.2.9 or later.

Risk factor :

Medium / CVSS Base Score : 4.3
CVSS Temporal Score : 3.6
Public Exploit Available : true

Family: Web Servers

Nessus Plugin ID: 33477 (apache_2_2_9.nasl)

Bugtraq ID: 27236

CVE ID: CVE-2007-6420