MS08-033: Vulnerabilities in DirectX Could Allow Remote Code Execution (951698)

This script is Copyright (C) 2008-2013 Tenable Network Security, Inc.


Synopsis :

A vulnerability in DirectX could allow remote code execution.

Description :

The remote host contains a version of DirectX that is affected by a
remote code execution vulnerability.

To exploit this flaw, an attacker would need to send a specially
malformed MPEG or SAMI file to a user on the remote host and have him
open it.

See also :

http://technet.microsoft.com/en-us/security/bulletin/ms08-033

Solution :

Microsoft has released a set of patches for Windows 2000, XP, 2003,
Vista and 2008.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 6.9
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: Windows : Microsoft Bulletins

Nessus Plugin ID: 33135 ()

Bugtraq ID: 29578
29581

CVE ID: CVE-2008-0011
CVE-2008-1444