IBM Lotus Domino < 8.0.1 / 7.0.3 FP1 Multiple Vulnerabilities

This script is Copyright (C) 2008-2011 Tenable Network Security, Inc.


Synopsis :

The remote web server is affected by multiple vulnerabilities.

Description :

According to its banner, the version of Lotus Domino on the remote
host is older than 8.0.1 / 7.0.3 FP1. The web server component of
such versions is reportedly affected by a stack overflow that can be
triggered by means of a specially crafted 'Accept-Language' request
header. While IBM says this only results in a denial of service, the
original researchers claim to have a working proof-of-concept for
Windows that allows arbitrary code execution with LOCAL SYSTEM
privileges.

In addition, the web server reportedly has an unspecified cross-site
scripting vulnerability in its servlet engine / Web container.

See also :

http://www.nessus.org/u?a3b5cab6
http://www-1.ibm.com/support/docview.wss?uid=swg21303057
http://www-1.ibm.com/support/docview.wss?uid=swg21303296

Solution :

Upgrade to Lotus Domino 8.0.1 / 7.0.3 FP1 or later.

Risk factor :

Critical / CVSS Base Score : 10.0
(CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.3
(CVSS2#E:F/RL:OF/RC:C)
Public Exploit Available : true

Family: Web Servers

Nessus Plugin ID: 32433 (domino_7_0_3fp1.nasl)

Bugtraq ID: 29310
29311

CVE ID: CVE-2008-2240
CVE-2008-2410