Ubuntu 7.04 / 7.10 / 8.04 LTS : ssl-cert vulnerability (USN-612-4)

Ubuntu Security Notice (C) 2008-2013 Canonical, Inc. / NASL script (C) 2008-2013 Tenable Network Security, Inc.

Synopsis :

The remote Ubuntu host is missing a security-related patch.

Description :

USN-612-1 fixed vulnerabilities in openssl. This update provides the
corresponding updates for ssl-cert -- potentially compromised
snake-oil SSL certificates will be regenerated.

A weakness has been discovered in the random number generator used by
OpenSSL on Debian and Ubuntu systems. As a result of this weakness,
certain encryption keys are much more common than they should be, such
that an attacker could guess the key through a brute-force attack
given minimal knowledge of the system. This particularly affects the
use of encryption keys in OpenSSH, OpenVPN and SSL certificates.

This vulnerability only affects operating systems which
(like Ubuntu) are based on Debian. However, other systems
can be indirectly affected if weak keys are imported into

We consider this an extremely serious vulnerability, and
urge all users to act immediately to secure their systems.

== Who is affected ==

Systems which are running any of the following releases :

* Ubuntu 7.04 (Feisty) * Ubuntu 7.10 (Gutsy) * Ubuntu 8.04
LTS (Hardy) * Ubuntu 'Intrepid Ibex' (development): libssl
<= 0.9.8g-8 * Debian 4.0 (etch) (see corresponding Debian
security advisory)

and have openssh-server installed or have been used to
create an OpenSSH key or X.509 (SSL) certificate.

All OpenSSH and X.509 keys generated on such systems must be
considered untrustworthy, regardless of the system on which
they are used, even after the update has been applied.

This includes the automatically generated host keys used by
OpenSSH, which are the basis for its server spoofing and
man-in-the-middle protection.

Solution :

Update the affected ssl-cert package.

Risk factor :

High / CVSS Base Score : 7.8
CVSS Temporal Score : 6.4
Public Exploit Available : true

Family: Ubuntu Local Security Checks

Nessus Plugin ID: 32358 ()

Bugtraq ID: 29179

CVE ID: CVE-2008-0166