GLSA-200805-02 : phpMyAdmin: Information disclosure

This script is Copyright (C) 2008-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-200805-02
(phpMyAdmin: Information disclosure)

Cezary Tomczak reported that an undefined UploadDir variable exposes an
information disclosure vulnerability when running on shared hosts.

Impact :

A remote attacker with CREATE TABLE permissions can exploit this
vulnerability via a specially crafted HTTP POST request in order to
read arbitrary files.

Workaround :

There is no known workaround at this time.

See also :

http://www.gentoo.org/security/en/glsa/glsa-200805-02.xml

Solution :

All phpMyAdmin users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=dev-db/phpmyadmin-2.11.5.2'

Risk factor :

Low / CVSS Base Score : 3.5
(CVSS2#AV:N/AC:M/Au:S/C:P/I:N/A:N)

Family: Gentoo Local Security Checks

Nessus Plugin ID: 32150 (gentoo_GLSA-200805-02.nasl)

Bugtraq ID:

CVE ID: CVE-2008-1924