Slackware 10.0 / 10.1 / 10.2 / 11.0 / 12.0 / current : xine-lib (SSA:2008-111-01)

This script is Copyright (C) 2008-2013 Tenable Network Security, Inc.


Synopsis :

The remote Slackware host is missing a security update.

Description :

New xine-lib packages are available for Slackware 10.0, 10.1, 10.2,
11.0, 12.0, and -current to fix security issues. An overflow was found
in the Speex decoder that could lead to a crash or possible execution
of arbitrary code. Xine-lib <= 1.1.12 was also found to be vulnerable
to a stack-based buffer overflow in the NES demuxer (thanks to
milw0rm.com).

See also :

http://www.nessus.org/u?ac852785

Solution :

Update the affected xine-lib package.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)

Family: Slackware Local Security Checks

Nessus Plugin ID: 32033 ()

Bugtraq ID:

CVE ID: CVE-2008-1686