Apache < 2.2.3 mod_rewrite LDAP Protocol URL Handling Overflow

This script is Copyright (C) 2008-2013 Tenable Network Security, Inc.


Synopsis :

The remote version of Apache is vulnerable to an off-by-one buffer
overflow attack.

Description :

The remote host appears to be running a version of Apache which is
older than 2.2.3.

This version is vulnerable to an off-by-one buffer overflow attack in
the mod_rewrite module.

See also :

http://www.apache.org/dist/httpd/Announcement.html

Solution :

Upgrade to version 2.2.3.

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 6.2
(CVSS2#E:F/RL:OF/RC:C)
Public Exploit Available : true

Family: Web Servers

Nessus Plugin ID: 31659 (apache_2_2_3.nasl)

Bugtraq ID: 19204

CVE ID: CVE-2006-3747
CVE-2006-4154