Apache < 1.3.37 mod_rewrite LDAP Protocol URL Handling Overflow

This script is Copyright (C) 2008-2014 Tenable Network Security, Inc.


Synopsis :

The remote version of Apache is vulnerable to an off-by-one buffer
overflow attack.

Description :

The remote host appears to be running a version of Apache which is
older than 1.3.37.

This version contains an off-by-one buffer overflow in the mod_rewrite
module.

See also :

http://seclists.org/fulldisclosure/2006/Jul/671
http://www.securityfocus.com/archive//443870

Solution :

Upgrade to version 1.3.37 or later.

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 6.2
(CVSS2#E:F/RL:OF/RC:C)
Public Exploit Available : true

Family: Web Servers

Nessus Plugin ID: 31654 (apache_1_3_37.nasl)

Bugtraq ID: 19204

CVE ID: CVE-2006-3747