Apache < 2.0.63 Multiple XSS Vulnerabilities

This script is Copyright (C) 2008-2015 Tenable Network Security, Inc.

Synopsis :

The remote web server is affected by multiple cross-site scripting

Description :

According to its banner, the version of Apache 2.0.x running on the
remote host is prior to 2.0.63. It is, therefore, affected by multiple
cross-site scripting vulnerabilities :

- A cross-site scripting issue involving mod_imap.

- A cross-site scripting issue involving 413 error pages
via a malformed HTTP method. (PR 44014 / CVE-2007-6203)

- A cross-site scripting issue in mod_status involving the
refresh parameter. (CVE-2007-6388)

- A cross-site scripting issue using UTF-7 encoding in
mod_proxy_ftp exists because it does not define a
charset. (CVE-2008-0005)

Note that the remote web server may not actually be affected by these
vulnerabilities. Nessus did not try to determine whether the affected
modules are in use or to check for the issues themselves.

See also :


Solution :

Upgrade to Apache version 2.0.63 or later. Alternatively, ensure that
he affected modules are not in use.

Risk factor :

Medium / CVSS Base Score : 4.3
CVSS Temporal Score : 3.7
Public Exploit Available : true

Family: Web Servers

Nessus Plugin ID: 31407 (apache_2_0_63.nasl)

Bugtraq ID: 26663

CVE ID: CVE-2007-5000