Apache 2.2.x < 2.2.8 Multiple Vulnerabilities (XSS, DoS)

This script is Copyright (C) 2008-2015 Tenable Network Security, Inc.


Synopsis :

The remote web server is affected by multiple vulnerabilities.

Description :

According to its banner, the version of Apache 2.2.x running on the
remote host is prior to 2.2.8. It is, therefore, affected by the
following vulnerabilities :

- A cross-site scripting issue involving mod_imagemap
(CVE-2007-5000).

- A cross-site scripting issue involving 413 error pages
via a malformed HTTP method (PR 44014 / CVE-2007-6203).

- A cross-site scripting issue in mod_status involving
the refresh parameter (CVE-2007-6388).

- A cross-site scripting issue in mod_proxy_balancer
involving the worker route and worker redirect
string of the balancer manager (CVE-2007-6421).

- A denial of service issue in the balancer_handler
function in mod_proxy_balancer can be triggered by
an authenticated user when a threaded Multi-
Processing Module is used (CVE-2007-6422).

- A cross-site scripting issue using UTF-7 encoding
in mod_proxy_ftp exists because it does not
define a charset (CVE-2008-0005).

Note that the remote web server may not actually be affected by these
vulnerabilities. Nessus did not try to determine whether the affected
modules are in use or to check for the issues themselves.

See also :

http://www.apache.org/dist/httpd/CHANGES_2.2
http://httpd.apache.org/security/vulnerabilities_22.html

Solution :

Upgrade to Apache version 2.2.8 or later. Alternatively, ensure that
the affected modules are not in use.

Risk factor :

Medium / CVSS Base Score : 4.3
(CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N)
CVSS Temporal Score : 3.7
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true

Family: Web Servers

Nessus Plugin ID: 31118 (apache_2_2_8.nasl)

Bugtraq ID: 26663
26838
27234
27236
27237

CVE ID: CVE-2007-5000
CVE-2007-6203
CVE-2007-6388
CVE-2007-6421
CVE-2007-6422
CVE-2008-0005