GLSA-200802-05 : Gnumeric: User-assisted execution of arbitrary code

This script is Copyright (C) 2008-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-200802-05
(Gnumeric: User-assisted execution of arbitrary code)

Multiple integer overflow and signedness errors have been reported in
the excel_read_HLINK() function in file plugins/excel/ms-excel-read.c
when processing XLS HLINK opcodes.

Impact :

A remote attacker could entice a user to open a specially crafted XLS
file, possibly resulting in the remote execution of arbitrary code with
the privileges of the user running the application.

Workaround :

There is no known workaround at this time.

See also :

http://www.gentoo.org/security/en/glsa/glsa-200802-05.xml

Solution :

All Gnumeric users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=app-office/gnumeric-1.8.1'

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)

Family: Gentoo Local Security Checks

Nessus Plugin ID: 31083 (gentoo_GLSA-200802-05.nasl)

Bugtraq ID:

CVE ID: CVE-2008-0668