Debian DSA-1480-1 : poppler - several vulnerabilities

This script is Copyright (C) 2008-2013 Tenable Network Security, Inc.


Synopsis :

The remote Debian host is missing a security-related update.

Description :

Alin Rad Pop discovered several buffer overflows in the Poppler PDF
library, which could allow the execution of arbitrary code if a
malformed PDF file is opened.

See also :

http://www.debian.org/security/2008/dsa-1480

Solution :

Upgrade the poppler packages.

The old stable distribution (sarge) doesn't contain poppler.

For the stable distribution (etch), these problems have been fixed in
version 0.4.5-5.1etch2.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)

Family: Debian Local Security Checks

Nessus Plugin ID: 30188 (debian_DSA-1480.nasl)

Bugtraq ID:

CVE ID: CVE-2007-4352
CVE-2007-5392
CVE-2007-5393