GLSA-200712-16 : Exiv2: Integer overflow

This script is Copyright (C) 2007-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-200712-16
(Exiv2: Integer overflow)

Meder Kydyraliev (Google Security) discovered an integer overflow
vulnerability in the JpegThumbnail::setDataArea() method leading to a
heap-based buffer overflow.

Impact :

An attacker could entice the user of an application making use of Exiv2
or an application included in Exiv2 to load an image file with
specially crafted Exif tags, possibly resulting in the execution of
arbitrary code with the privileges of the user running the application.

Workaround :

There is no known workaround at this time.

See also :

http://www.gentoo.org/security/en/glsa/glsa-200712-16.xml

Solution :

All Exiv2 users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=media-gfx/exiv2-0.13-r1'

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)

Family: Gentoo Local Security Checks

Nessus Plugin ID: 29813 (gentoo_GLSA-200712-16.nasl)

Bugtraq ID:

CVE ID: CVE-2007-6353