Squid < 2.6.STABLE18 Cache Update Reply Unspecified DoS

This script is Copyright (C) 2007-2014 Tenable Network Security, Inc.


Synopsis :

The remote proxy server is prone to a denial of service attack.

Description :

According to its banner, the version of the Squid proxy caching server
installed on the remote host is older than 2.6.STABLE18. Such versions
reportedly use incorrect bounds checking when processing some cache
update replies. A client trusted to use the service may be able to
leverage this issue to crash the application, thereby denying service
to legitimate users.

Note that an earlier version of the advisory said 2.6.STABLE17 fixed
the issue, but it turned out that the patch did not fully address the
issue.

See also :

http://www.squid-cache.org/Advisories/SQUID-2007_2.txt
http://www.securityfocus.com/archive/1/484662/30/0/threaded

Solution :

Either upgrade to Squid version 2.6.STABLE18 or later or apply the
patch referenced in the project's advisory above.

Risk factor :

Medium / CVSS Base Score : 5.0
(CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P)
CVSS Temporal Score : 3.7
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: Firewalls

Nessus Plugin ID: 29216 ()

Bugtraq ID: 26687
28693

CVE ID: CVE-2007-6239
CVE-2008-1612