IBM DB2 < 9 Fix Pack 4 Multiple Vulnerabilities

This script is Copyright (C) 2007-2015 Tenable Network Security, Inc.

Synopsis :

The remote database server is affected by multiple vulnerabilities.

Description :

According to its version, the installation of IBM DB2 running on the
remote host is affected by one or more of the following issues :

- The 'db2dart' tool executes the 'tput' command which
effectively allows a malicious user to run commands
as the DB2 instance owner (IZ03646).

- 'db2watch' and 'db2freeze' have some unspecified
vulnerability (IZ03655).

- Incorrect permissions on ACLs for 'DB2NODES.CFG'

- A local user may be able to gain root privileges using
an unspecified vulnerability in several set-uid
binaries (IZ07018).

- A buffer overflow and invalid memory access
vulnerability exists in the DAS server code (unknown).

See also :

Solution :

Apply IBM DB2 version 9 Fix Pack 4 or later.

Risk factor :

Critical / CVSS Base Score : 10.0
CVSS Temporal Score : 8.3
Public Exploit Available : true