Ubuntu 5.10 / 6.06 LTS / 6.10 : geoip vulnerability (USN-412-1)

Ubuntu Security Notice (C) 2007-2013 Canonical, Inc. / NASL script (C) 2007-2013 Tenable Network Security, Inc.


Synopsis :

The remote Ubuntu host is missing one or more security-related patches.

Description :

Dean Gaudet discovered that the GeoIP update tool did not validate the
filename responses from the update server. A malicious server, or
man-in-the-middle system posing as a server, could write to arbitrary
files with user privileges.

Solution :

Update the affected geoip-bin, libgeoip-dev and / or libgeoip1
packages.

Risk factor :

Medium / CVSS Base Score : 6.4
(CVSS2#AV:N/AC:L/Au:N/C:N/I:P/A:P)
CVSS Temporal Score : 5.5
(CVSS2#E:F/RL:TF/RC:ND)
Public Exploit Available : true

Family: Ubuntu Local Security Checks

Nessus Plugin ID: 28001 ()

Bugtraq ID: 21959

CVE ID: CVE-2007-0159