Ubuntu 5.10 / 6.06 LTS / 6.10 : w3m vulnerabilities (USN-399-1)

Ubuntu Security Notice (C) 2007-2016 Canonical, Inc. / NASL script (C) 2007-2016 Tenable Network Security, Inc.


Synopsis :

The remote Ubuntu host is missing one or more security-related
patches.

Description :

A format string vulnerability was discovered in w3m. If a user were
tricked into visiting an HTTPS URL protected by a specially crafted
SSL certificate, an attacker could execute arbitrary code with user
privileges.

Note that Tenable Network Security has extracted the preceding
description block directly from the Ubuntu security advisory. Tenable
has attempted to automatically clean and format it as much as possible
without introducing additional issues.

Solution :

Update the affected w3m and / or w3m-img packages.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.1
(CVSS2#E:ND/RL:OF/RC:ND)
Public Exploit Available : false

Family: Ubuntu Local Security Checks

Nessus Plugin ID: 27987 ()

Bugtraq ID: 21735

CVE ID: CVE-2006-6772