GLSA-200711-01 : gFTP: Multiple vulnerabilities

This script is Copyright (C) 2007-2015 Tenable Network Security, Inc.

Synopsis :

The remote Gentoo host is missing one or more security-related

Description :

The remote host is affected by the vulnerability described in GLSA-200711-01
(gFTP: Multiple vulnerabilities)

Kalle Olavi Niemitalo discovered two boundary errors in fsplib code
included in gFTP when processing overly long directory or file names.

Impact :

A remote attacker could trigger these vulnerabilities by enticing a
user to download a file with a specially crafted directory or file
name, possibly resulting in the execution of arbitrary code
(CVE-2007-3962) or a Denial of Service (CVE-2007-3961).

Workaround :

There is no known workaround at this time.

See also :

Solution :

All gFTP users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=net-ftp/gftp-2.0.18-r6'

Risk factor :

High / CVSS Base Score : 7.5

Family: Gentoo Local Security Checks

Nessus Plugin ID: 27611 (gentoo_GLSA-200711-01.nasl)

Bugtraq ID:

CVE ID: CVE-2007-3961