ProFTPD < 1.3.0a Multiple Vulnerabilities

This script is Copyright (C) 2007-2014 Tenable Network Security, Inc.


Synopsis :

The remote FTP server is affected by several vulnerabilities.

Description :

The remote host is using ProFTPD, a free FTP server for Unix and
Linux.

According to its banner, the version of ProFTPD installed on the
remote host is earlier than 1.3.0a. As such, it may be affected by one
or more of the following vulnerabilities :

- An off-by-one string manipulation flaw exists in the
'sreplace' function. (CVE-2006-5815)

- A buffer overflow exists in the 'tls_x509_name_oneline'
function of the mod_tls module involving the data
length argument. (CVE-2006-6170)

- An off-by-two buffer overflow exists due to a failure
to properly set the buffer size limit when
'CommandBufferSize' is specified in the configuration
file, an issue which is disputed by the developers.
(CVE-2006-6171)

An attacker may be able to leverage this issue to crash the affected
service or execute arbitrary code remotely, subject to the privileges
under which the application operates.

See also :

http://archives.neohapsis.com/archives/bugtraq/2006-11/0095.html
http://www.securityfocus.com/archive/1/452760/30/0/threaded

Solution :

Upgrade to ProFTPD version 1.3.0a or later.

Risk factor :

Critical / CVSS Base Score : 10.0
(CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.3
(CVSS2#E:F/RL:OF/RC:C)
Public Exploit Available : true

Family: FTP

Nessus Plugin ID: 27055 ()

Bugtraq ID: 20992

CVE ID: CVE-2006-5815
CVE-2006-6170
CVE-2006-6171