RHEL 4 / 5 : elinks (RHSA-2007:0933)

This script is Copyright (C) 2007-2014 Tenable Network Security, Inc.


Synopsis :

The remote Red Hat host is missing a security update.

Description :

An updated ELinks package that corrects a security vulnerability is
now available for Red Hat Enterprise Linux 4 and 5.

This update has been rated as having moderate security impact by the
Red Hat Security Response Team.

ELinks is a text mode Web browser used from the command line that
supports rendering modern web pages.

An information disclosure flaw was found in the way ELinks passes
https POST data to a proxy server. POST data sent via a proxy to an
https site is not properly encrypted by ELinks, possibly allowing the
disclosure of sensitive information. (CVE-2007-5034)

All users of Elinks are advised to upgrade to this updated package,
which contains a backported patch that resolves this issue.

See also :

https://www.redhat.com/security/data/cve/CVE-2007-5034.html
http://rhn.redhat.com/errata/RHSA-2007-0933.html

Solution :

Update the affected elinks package.

Risk factor :

Medium / CVSS Base Score : 4.3
(CVSS2#AV:N/AC:M/Au:N/C:P/I:N/A:N)

Family: Red Hat Local Security Checks

Nessus Plugin ID: 26954 ()

Bugtraq ID:

CVE ID: CVE-2007-5034