GLSA-200709-07 : Eggdrop: Buffer overflow

This script is Copyright (C) 2007-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-200709-07
(Eggdrop: Buffer overflow)

Bow Sineath discovered a boundary error in the file
mod/server.mod/servrmsg.c when processing overly long private messages
sent by an IRC server.

Impact :

A remote attacker could entice an Eggdrop user to connect the bot to a
malicious server, possibly resulting in the execution of arbitrary code
on the host running Eggdrop.

Workaround :

There is no known workaround at this time.

See also :

http://www.gentoo.org/security/en/glsa/glsa-200709-07.xml

Solution :

All Eggdrop users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=net-irc/eggdrop-1.6.18-r3'

Risk factor :

Medium / CVSS Base Score : 6.8
(CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P)

Family: Gentoo Local Security Checks

Nessus Plugin ID: 26097 (gentoo_GLSA-200709-07.nasl)

Bugtraq ID:

CVE ID: CVE-2007-2807