Apache 2.2.x < 2.2.6 Multiple Vulnerabilities (DoS, XSS, Info Disc)

This script is Copyright (C) 2007-2015 Tenable Network Security, Inc.

Synopsis :

The remote web server is affected by multiple vulnerabilities.

Description :

According to its banner, the version of Apache 2.2.x running on the
remote host is prior to 2.2.6. It is, therefore, affected by the
following vulnerabilities :

- A denial of service vulnerability in mod_proxy.
- A cross-site scripting vulnerability in mod_status.
- A local denial of service vulnerability associated with
the Prefork MPM module.
- An information leak in mod_cache.
- A denial of service vulnerability in mod_cache.

In addition, it offers a workaround for a cross-site scripting issue
in mod_autoindex.

Note that the remote web server may not actually be affected by these
vulnerabilities. Nessus did not try to determine whether any of the
affected modules are in use on the remote server or to check for the
issues themselves.

See also :


Solution :

Upgrade to Apache version 2.2.6 or later. Alternatively, ensure that
the affected modules are not in use.

Risk factor :

Medium / CVSS Base Score : 5.0
CVSS Temporal Score : 4.1
Public Exploit Available : true