Asterisk SIP Channel T.38 SDP Parsing Multiple Buffer Overflows

This script is Copyright (C) 2007-2013 Tenable Network Security, Inc.

Synopsis :

The remote server is affected by two buffer overflow vulnerabilities.

Description :

The version of Asterisk installed on the remote host contains two
stack-based buffer overflows in its SIP SDP handler when attempting to
read the 'T38FaxRateManagement:' and 'T38FaxUdpEC:' options in the SDP
within a SIP packet. An unauthenticated, remote attacker may be able
to leverage this flaw to execute code on the affected host subject to
the privileges under which Asterisk runs.

See also :

Solution :

Either disable T.38 support or upgrade to Asterisk 1.4.3 / AsteriskNow
Beta 6 or later.

Risk factor :

High / CVSS Base Score : 7.6
CVSS Temporal Score : 6.3
Public Exploit Available : true

Family: Gain a shell remotely

Nessus Plugin ID: 25671 (asterisk_sip_t38_sdp_overflow.nasl)

Bugtraq ID: 23648

CVE ID: CVE-2007-2293