GLSA-200705-25 : file: Integer overflow

This script is Copyright (C) 2007-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-200705-25
(file: Integer overflow)

Colin Percival from FreeBSD reported that the previous fix for the
file_printf() buffer overflow introduced a new integer overflow.

Impact :

A remote attacker could entice a user to run the file program on an
overly large file (more than 1Gb) that would trigger an integer
overflow on 32-bit systems, possibly leading to the execution of
arbitrary code with the rights of the user running file.

Workaround :

There is no known workaround at this time.

See also :

http://www.gentoo.org/security/en/glsa/glsa-200705-25.xml

Solution :

Since file is a system package, all Gentoo users should upgrade to the
latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=sys-apps/file-4.21'

Risk factor :

Medium / CVSS Base Score : 5.1
(CVSS2#AV:N/AC:H/Au:N/C:P/I:P/A:P)

Family: Gentoo Local Security Checks

Nessus Plugin ID: 25384 (gentoo_GLSA-200705-25.nasl)

Bugtraq ID:

CVE ID: CVE-2007-2799