MySQL 5.1 < 5.1.18 Multiple Vulnerabilities

This script is Copyright (C) 2007-2014 Tenable Network Security, Inc.

Synopsis :

The remote database server is affected by multiple vulnerabilities.

Description :

The version of MySQL installed on the remote host reportedly is
affected by several issues :

- Evaluation of an 'IN()' predicate with a decimal-valued
argument causes a service crash.

- A user can rename a table even though he does not have
DROP privileges.

- If a stored routine is declared as 'SQL SECURITY INVOKER',
a user may be able to gain privileges by invoking that

- A user with only ALTER privileges on a partitioned table
can discover information about the table that should
require SELECT privileges.

See also :

Solution :

Upgrade to MySQL version 5.1.18 or later.

Risk factor :

Medium / CVSS Base Score : 6.0
CVSS Temporal Score : 4.7
Public Exploit Available : true

Family: Databases

Nessus Plugin ID: 25242 ()

Bugtraq ID: 23911

CVE ID: CVE-2007-2583