CommuniGate Pro WebMail w/ MSIE STYLE Tag XSS

This script is Copyright (C) 2007-2014 Tenable Network Security, Inc.


Synopsis :

The remote web server is affected by a cross-site scripting issue.

Description :

According to its banner, the version of CommuniGate Pro running on the
remote host fails to completely sanitize email messages, when using
Internet Explorer (IE). A remote attacker may be able to leverage this
issue to inject arbitrary HTML and script code into a user's browser to
be evaluated within the security context of the affected website.

See also :

http://archives.neohapsis.com/archives/fulldisclosure/2007-05/0186.html
http://www.communigate.com/CommuniGatePro/History51.html

Solution :

Upgrade to CommuniGate Pro version 5.1.9 or later.

Risk factor :

Medium / CVSS Base Score : 4.3
(CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N)
CVSS Temporal Score : 3.6
(CVSS2#E:F/RL:OF/RC:C)
Public Exploit Available : true

Family: CGI abuses : XSS

Nessus Plugin ID: 25215 (communigatepro_519.nasl)

Bugtraq ID: 23950

CVE ID: CVE-2007-2718