GLSA-200704-12 : OpenOffice.org: Multiple vulnerabilities

This script is Copyright (C) 2007-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-200704-12
(OpenOffice.org: Multiple vulnerabilities)

John Heasman of NGSSoftware has discovered a stack-based buffer
overflow in the StarCalc parser and an input validation error when
processing metacharacters in a link. Also OpenOffice.Org includes code
from libwpd making it vulnerable to heap-based overflows when
converting WordPerfect document tables (GLSA 200704-07).

Impact :

A remote attacker could entice a user to open a specially crafted
document, possibly leading to execution of arbitrary code with the
rights of the user running OpenOffice.org.

Workaround :

There is no known workaround at this time.

See also :

http://www.gentoo.org/security/en/glsa/glsa-200704-07.xml
http://www.gentoo.org/security/en/glsa/glsa-200704-12.xml

Solution :

All OpenOffice.org users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=app-office/openoffice-2.1.0-r1'
All OpenOffice.org binary users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=app-office/openoffice-bin-2.2.0'

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)

Family: Gentoo Local Security Checks

Nessus Plugin ID: 25057 (gentoo_GLSA-200704-12.nasl)

Bugtraq ID:

CVE ID: CVE-2007-0002
CVE-2007-0238
CVE-2007-0239