MySQL Single Row Subselect Remote DoS

This script is Copyright (C) 2007-2014 Tenable Network Security, Inc.


Synopsis :

The remote database server is prone to a denial of service attack.

Description :

According to its banner, the version of MySQL on the remote host is
older than 5.0.37. Such versions are vulnerable to a remote denial of
service when processing certain single row subselect queries. A
malicious user can crash the service via a specially crafted SQL
query.

See also :

http://www.sec-consult.com/284.html
http://www.securityfocus.com/archive/1/archive/1/462339/100/0/threaded
http://dev.mysql.com/doc/refman/5.0/en/news-5-0-37.html

Solution :

Upgrade to MySQL version 5.0.37 or newer.

Risk factor :

Low / CVSS Base Score : 2.1
(CVSS2#AV:L/AC:L/Au:N/C:N/I:N/A:P)
CVSS Temporal Score : 1.7
(CVSS2#E:F/RL:OF/RC:C)
Public Exploit Available : true

Family: Databases

Nessus Plugin ID: 24905 ()

Bugtraq ID: 22900

CVE ID: CVE-2007-1420