GLSA-200701-21 : MIT Kerberos 5: Arbitrary Remote Code Execution

This script is Copyright (C) 2007-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-200701-21
(MIT Kerberos 5: Arbitrary Remote Code Execution)

The Kerberos administration daemon, and possibly other applications
using the GSS-API or RPC libraries, could potentially call a function
pointer in a freed heap buffer, or attempt to free an uninitialized
pointer.

Impact :

A remote attacker may be able to crash an affected application, or
potentially execute arbitrary code with root privileges.

Workaround :

There is no known workaround at this time.

See also :

http://www.gentoo.org/security/en/glsa/glsa-200701-21.xml

Solution :

All MIT Kerberos 5 users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=app-crypt/mit-krb5-1.5.2'

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)

Family: Gentoo Local Security Checks

Nessus Plugin ID: 24257 (gentoo_GLSA-200701-21.nasl)

Bugtraq ID:

CVE ID: CVE-2006-6143
CVE-2006-6144