IBM DB2 < 8.1 FixPak 12 EXCSAT Long MGRLVLLS Message Remote DoS

This script is Copyright (C) 2006-2015 Tenable Network Security, Inc.

Synopsis :

The remote database server is affected by a denial of service vulnerability.

Description :

According to its version, the installation of IBM DB2 running on the
remote host may crash when it attempts to process a specially crafted
CONNECT or ATTACH request sent during the initial handshake process.
An unauthenticated, remote attacker can exploit this issue to overflow
a buffer and crash the database instance, thereby denying service to
legitimate users.

See also :

Solution :

Apply IBM DB2 UDB version 8.1 Fix Pack 12 or later.

Risk factor :

Medium / CVSS Base Score : 5.0
CVSS Temporal Score : 3.7
Public Exploit Available : false

Family: Databases

Nessus Plugin ID: 23935 (db2_81fp12.nasl)

Bugtraq ID: 18428

CVE ID: CVE-2006-3066