GLSA-200611-19 : ImageMagick: PALM and DCM buffer overflows

This script is Copyright (C) 2006-2015 Tenable Network Security, Inc.

Synopsis :

The remote Gentoo host is missing one or more security-related

Description :

The remote host is affected by the vulnerability described in GLSA-200611-19
(ImageMagick: PALM and DCM buffer overflows)

M. Joonas Pihlaja has reported that a boundary error exists within the
ReadDCMImage() function of coders/dcm.c, causing the improper handling
of DCM images. Pihlaja also reported that there are several boundary
errors in the ReadPALMImage() function of coders/palm.c, similarly
causing the improper handling of PALM images.

Impact :

An attacker could entice a user to open a specially crafted DCM or PALM
image with ImageMagick, and possibly execute arbitrary code with the
privileges of the user running ImageMagick.

Workaround :

There is no known workaround at this time.

See also :

Solution :

All ImageMagick users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=media-gfx/imagemagick-'

Risk factor :

Medium / CVSS Base Score : 5.1
CVSS Temporal Score : 4.4
Public Exploit Available : false

Family: Gentoo Local Security Checks

Nessus Plugin ID: 23727 (gentoo_GLSA-200611-19.nasl)

Bugtraq ID: 20707

CVE ID: CVE-2006-5456