GLSA-200611-18 : TIN: Multiple buffer overflows

This script is Copyright (C) 2006-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-200611-18
(TIN: Multiple buffer overflows)

Urs Janssen and Aleksey Salow have reported multiple buffer overflows
in TIN. Additionally, the OpenPKG project has reported an allocation
off-by-one flaw which can lead to a buffer overflow.

Impact :

An attacker could entice a TIN user to read a specially crafted news
article, and execute arbitrary code with the rights of the user running
TIN.

Workaround :

There is no known workaround at this time.

See also :

http://www.nessus.org/u?48a7da07
http://www.gentoo.org/security/en/glsa/glsa-200611-18.xml

Solution :

All TIN users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=net-nntp/tin-1.8.2'

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)

Family: Gentoo Local Security Checks

Nessus Plugin ID: 23726 (gentoo_GLSA-200611-18.nasl)

Bugtraq ID:

CVE ID: CVE-2006-0804