GLSA-200611-16 : Texinfo: Buffer overflow

This script is Copyright (C) 2006-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-200611-16
(Texinfo: Buffer overflow)

Miloslav Trmac from Red Hat discovered a buffer overflow in the
'readline()' function of texindex.c. The 'readline()' function is
called by the texi2dvi and texindex commands.

Impact :

By enticing a user to open a specially crafted Texinfo file, an
attacker could execute arbitrary code with the rights of the user
running Texinfo.

Workaround :

There is no known workaround at this time.

See also :

http://www.gentoo.org/security/en/glsa/glsa-200611-16.xml

Solution :

All Texinfo users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=sys-apps/texinfo-4.8-r5'

Risk factor :

Medium / CVSS Base Score : 4.6
(CVSS2#AV:L/AC:L/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 4.0
(CVSS2#E:ND/RL:OF/RC:ND)
Public Exploit Available : false

Family: Gentoo Local Security Checks

Nessus Plugin ID: 23710 (gentoo_GLSA-200611-16.nasl)

Bugtraq ID: 20959

CVE ID: CVE-2006-4810