GLSA-200611-13 : message vulnerability

This script is Copyright (C) 2006-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-200611-13
(message vulnerability)

Avahi does not check that the netlink messages come from the kernel
instead of a user-space process.

Impact :

A local attacker could exploit this vulnerability by crafting malicious
netlink messages and trick Avahi to react to fake network changes. This
could lead users to connect to untrusted services without knowing.

Workaround :

There is no known workaround at this time.

See also :

http://www.gentoo.org/security/en/glsa/glsa-200611-13.xml

Solution :

All Avahi users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=net-dns/avahi-0.6.15'

Risk factor :

Low / CVSS Base Score : 2.1
(CVSS2#AV:L/AC:L/Au:N/C:N/I:P/A:N)

Family: Gentoo Local Security Checks

Nessus Plugin ID: 23707 (gentoo_GLSA-200611-13.nasl)

Bugtraq ID:

CVE ID: CVE-2006-5461