Debian DSA-1015-1 : sendmail - programming error

This script is Copyright (C) 2006-2013 Tenable Network Security, Inc.


Synopsis :

The remote Debian host is missing a security-related update.

Description :

Mark Dowd discovered a flaw in the handling of asynchronous signals in
sendmail, a powerful, efficient, and scalable mail transport agent.
This allows a remote attacker to exploit a race condition to execute
arbitrary code as root.

See also :

http://www.debian.org/security/2006/dsa-1015

Solution :

Upgrade the sendmail package immediately.

For the old stable distribution (woody) this problem has been fixed in
version 8.12.3-7.2.

For the stable distribution (sarge) this problem has been fixed in
version 8.13.4-3sarge1.

Risk factor :

High / CVSS Base Score : 7.6
(CVSS2#AV:N/AC:H/Au:N/C:C/I:C/A:C)

Family: Debian Local Security Checks

Nessus Plugin ID: 22557 (debian_DSA-1015.nasl)

Bugtraq ID:

CVE ID: CVE-2006-0058