GLSA-200609-20 : DokuWiki: Shell command injection and Denial of Service

This script is Copyright (C) 2006-2015 Tenable Network Security, Inc.

Synopsis :

The remote Gentoo host is missing one or more security-related

Description :

The remote host is affected by the vulnerability described in GLSA-200609-20
(DokuWiki: Shell command injection and Denial of Service)

Input validation flaws have been discovered in the image handling of
fetch.php if ImageMagick is used, which is not the default method.

Impact :

A remote attacker could exploit the flaws to execute arbitrary shell
commands with the rights of the web server daemon or cause a Denial of

Workaround :

There is no known workaround at this time.

See also :

Solution :

All DokuWiki users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=www-apps/dokuwiki-20060309e'

Risk factor :

High / CVSS Base Score : 7.5

Family: Gentoo Local Security Checks

Nessus Plugin ID: 22471 (gentoo_GLSA-200609-20.nasl)

Bugtraq ID:

CVE ID: CVE-2006-5098