GLSA-200609-14 : ImageMagick: Multiple Vulnerabilities

This script is Copyright (C) 2006-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-200609-14
(ImageMagick: Multiple Vulnerabilities)

Tavis Ormandy of the Google Security Team discovered a stack and heap
buffer overflow in the GIMP XCF Image decoder and multiple heap and
integer overflows in the SUN bitmap decoder. Damian Put discovered a
heap overflow in the SGI image decoder.

Impact :

An attacker may be able to create a specially crafted image that, when
processed with ImageMagick, executes arbitrary code with the privileges
of the executing user.

Workaround :

There is no known workaround at this time.

See also :

http://www.gentoo.org/security/en/glsa/glsa-200609-14.xml

Solution :

All ImageMagick users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=media-gfx/imagemagick-6.2.9.5'

Risk factor :

Medium / CVSS Base Score : 5.1
(CVSS2#AV:N/AC:H/Au:N/C:P/I:P/A:P)

Family: Gentoo Local Security Checks

Nessus Plugin ID: 22458 (gentoo_GLSA-200609-14.nasl)

Bugtraq ID:

CVE ID: CVE-2006-3743
CVE-2006-3744
CVE-2006-4144