GLSA-200608-28 : PHP: Arbitary code execution

This script is Copyright (C) 2006-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-200608-28
(PHP: Arbitary code execution)

The sscanf() PHP function contains an array boundary error that can be
exploited to dereference a NULL pointer. This can possibly allow the
bypass of the safe mode protection by executing arbitrary code.

Impact :

A remote attacker might be able to exploit this vulnerability in PHP
applications making use of the sscanf() function, potentially resulting
in the execution of arbitrary code or the execution of scripted
contents in the context of the affected site.

Workaround :

There is no known workaround at this time.

See also :

http://www.gentoo.org/security/en/glsa/glsa-200608-28.xml

Solution :

All PHP 4.x users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=dev-lang/php-4.4.3-r1'
All PHP 5.x users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=dev-lang/php-5.1.4-r6'

Risk factor :

Medium / CVSS Base Score : 4.6
(CVSS2#AV:L/AC:L/Au:N/C:P/I:P/A:P)

Family: Gentoo Local Security Checks

Nessus Plugin ID: 22290 (gentoo_GLSA-200608-28.nasl)

Bugtraq ID:

CVE ID: CVE-2006-4020