GLSA-200608-17 : libwmf: Buffer overflow vulnerability

This script is Copyright (C) 2006-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-200608-17
(libwmf: Buffer overflow vulnerability)

infamous41md discovered that libwmf fails to do proper bounds checking
on the MaxRecordSize variable in the WMF file header. This could lead
to an head-based buffer overflow.

Impact :

By enticing a user to open a specially crafted WMF file, a remote
attacker could cause a heap-based buffer overflow and execute arbitrary
code with the permissions of the user running the application that uses
libwmf.

Workaround :

There is no known workaround for this issue.

See also :

http://www.gentoo.org/security/en/glsa/glsa-200608-17.xml

Solution :

All libwmf users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=media-libs/libwmf-0.2.8.4'

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)

Family: Gentoo Local Security Checks

Nessus Plugin ID: 22216 (gentoo_GLSA-200608-17.nasl)

Bugtraq ID:

CVE ID: CVE-2006-3376