GLSA-200608-13 : ClamAV: Heap buffer overflow

This script is Copyright (C) 2006-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-200608-13
(ClamAV: Heap buffer overflow)

Damian Put has discovered a boundary error in the pefromupx() function
used by the UPX extraction module, which unpacks PE Windows executable
files. Both the 'clamscan' command-line utility and the 'clamd' daemon
are affected.

Impact :

By sending a malicious attachment to a mail server running ClamAV, a
remote attacker can cause a Denial of Service and potentially the
execution of arbitrary code with the permissions of the user running
ClamAV.

Workaround :

There is no known workaround at this time.

See also :

http://www.clamav.net/security/0.88.4.html
http://www.gentoo.org/security/en/glsa/glsa-200608-13.xml

Solution :

All ClamAV users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=app-antivirus/clamav-0.88.4'

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)

Family: Gentoo Local Security Checks

Nessus Plugin ID: 22199 (gentoo_GLSA-200608-13.nasl)

Bugtraq ID:

CVE ID: CVE-2006-4018