RHEL 2.1 / 3 / 4 : gnupg (RHSA-2006:0615)

This script is Copyright (C) 2006-2015 Tenable Network Security, Inc.


Synopsis :

The remote Red Hat host is missing a security update.

Description :

Updated GnuPG packages that fix a security issue is now available.

This update has been rated as having moderate security impact by the
Red Hat Security Response Team.

GnuPG is a utility for encrypting data and creating digital
signatures.

An integer overflow flaw was found in GnuPG. An attacker could create
a carefully crafted message packet with a large length that could
cause GnuPG to crash or possibly overwrite memory when opened.
(CVE-2006-3746)

All users of GnuPG are advised to upgrade to these updated packages,
which contain a backported patch to correct this issue.

See also :

https://www.redhat.com/security/data/cve/CVE-2006-3746.html
http://rhn.redhat.com/errata/RHSA-2006-0615.html

Solution :

Update the affected gnupg package.

Risk factor :

Medium / CVSS Base Score : 5.0
(CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P)
CVSS Temporal Score : 3.9
(CVSS2#E:POC/RL:OF/RC:C)
Public Exploit Available : true

Family: Red Hat Local Security Checks

Nessus Plugin ID: 22151 ()

Bugtraq ID: 19110

CVE ID: CVE-2006-3746