GLSA-200606-24 : wv2: Integer overflow

This script is Copyright (C) 2006-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-200606-24
(wv2: Integer overflow)

A boundary checking error was found in wv2, which could lead to an
integer overflow.

Impact :

An attacker could execute arbitrary code with the rights of the user
running the program that uses the library via a maliciously crafted
Microsoft Word document.

Workaround :

There is no known workaround at this time.

See also :

http://www.gentoo.org/security/en/glsa/glsa-200606-24.xml

Solution :

All wv2 users should update to the latest stable version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=app-text/wv2-0.2.3'

Risk factor :

Medium / CVSS Base Score : 6.5
(CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:P)

Family: Gentoo Local Security Checks

Nessus Plugin ID: 21750 (gentoo_GLSA-200606-24.nasl)

Bugtraq ID:

CVE ID: CVE-2006-2197