GLSA-200606-22 : aRts: Privilege escalation

This script is Copyright (C) 2006-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-200606-22
(aRts: Privilege escalation)

artswrapper fails to properly check whether it can drop privileges
accordingly if setuid() fails due to a user exceeding assigned resource
limits.

Impact :

Local attackers could exploit this vulnerability to execute arbitrary
code with elevated privileges. Note that the aRts package provided by
Gentoo is only vulnerable if the artswrappersuid USE-flag is enabled.

Workaround :

There is no known workaround at this time.

See also :

http://www.gentoo.org/security/en/glsa/glsa-200606-22.xml

Solution :

All aRts users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose kde-base/arts

Risk factor :

Medium / CVSS Base Score : 6.0
(CVSS2#AV:L/AC:H/Au:S/C:C/I:C/A:C)

Family: Gentoo Local Security Checks

Nessus Plugin ID: 21742 (gentoo_GLSA-200606-22.nasl)

Bugtraq ID:

CVE ID: CVE-2006-2916