GLSA-200606-20 : Typespeed: Remote execution of arbitrary code

This script is Copyright (C) 2006-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-200606-20
(Typespeed: Remote execution of arbitrary code)

Niko Tyni discovered a buffer overflow in the addnewword() function of
Typespeed's network code.

Impact :

By sending specially crafted network packets to a machine running
Typespeed in multiplayer mode, a remote attacker can execute arbitrary
code with the permissions of the user running the game.

Workaround :

Do not run Typespeed in multiplayer mode. There is no known workaround
at this time for multiplayer mode.

See also :

http://www.gentoo.org/security/en/glsa/glsa-200606-20.xml

Solution :

All Typespeed users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=games-misc/typespeed-0.5.0'

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)

Family: Gentoo Local Security Checks

Nessus Plugin ID: 21732 (gentoo_GLSA-200606-20.nasl)

Bugtraq ID:

CVE ID: CVE-2006-1515